Allgemeiner Aufbau und Funktionen

Allgemeiner Aufbau und Funktionen

iMikel besteht aus mehreren einzelnen Modulen, die alle nach einem gleichen Layout-Muster aufgebaut sind. In diesem ersten Kapitel des Handbuchs erfahren Sie, wie iMikel allgemein aufgebaut ist. Dazu gehören verschiedene Bedienelemente und Funktionen, die Sie in vielen Bereichen des Programmes wiederfinden werden.

Öffnen der Programmhilfe

Sie können aus allen Modulen über das Menü Hilfe und den Eintrag iMikel - Handbuch das iMikel-Handbuch öffnen.

Im Handbuch wird anschließend direkt das Kapitel des Moduls geöffnet, aus welchem Sie den Menü-Aufruf gestartet haben.

Im Handbuch können Sie über die Pfeiltasten in der Kopfleiste durch die einzelnen Seiten blättern. Zudem steht Ihnen auf der linken Seite eine Stichwortliste zur Verfügung. Des Weiteren können Sie in der linken oberen Seite auch einen eigenen Suchbegriff eingeben.

Bei Auswahl eines Stichwortes oder nach Eingabe eines Suchbegriffes werden Ihnen direkt daneben alle Seitenzahlen angezeigt, auf denen der Begriff gefunden wurde. Mit einem Klick auf die Seitenzahl können Sie zu dieser Seite springen.

Über die Export-Taste in der Kopfleiste kann das Handbuch zudem als PDF-Datei exportiert werden, um es z. B. anschließend zu drucken.

In diesem Kapitel lernen Sie, wie Sie innerhalb des Programms navigieren können.

Öffnen von Modulen (Navigationsleiste)

Über die Navigationsleiste gelangen Sie in die verschiedenen Module in iMikel. Die Navigationsleiste befindet sich immer auf der linken Seite des Programms.

iMikel_Navigationsleiste.png

Klicken Sie auf eine Bezeichnung, um das jeweilige Modul zu öffnen. Jedes Modul wird dabei in einem separaten Fenster geöffnet und das zuletzt geöffnete Modul erscheint immer im Vordergrund.

Fenster-Management

Sie können beliebig viele Module gleichzeitig geöffnet haben. Ordnen Sie dazu einfach die Fenster der Module nebeneinander auf Ihrem Bildschirm an. Sie können so beispielsweise gleichzeitig in der Unterrichtsverwaltung und in der Lehrerverwaltung arbeiten.

Des Weiteren haben Sie die Möglichkeit, mehrere Fenster innerhalb eines Moduls zu öffnen. Um ein weiteres Fenster zu öffnen, wählen Sie unter dem Menüpunkt Fenster den Befehl Neues Fenster aus.

iMikel_Menue_Fenster_NeuesFenster.png

Über den Befehl Fensterpositionen speichern können Sie zudem die Position eines Fensters auf Ihrem Bildschirm speichern, sodass dieses immer wieder an derselben Stelle geöffnet wird.

Über den Befehl Alle Fensterpositionen zurücksetzen können Sie die zwischenzeitlich gespeicherten Fensterpositionen zurücksetzen. Es werden dann alle Fenster wieder grundsätzlich links oben positioniert.

Module mit Bezug öffnen

In iMikel sind die Module miteinander verknüpft. Das Programm erkennt somit automatisch, in welchen Bereichen eine Person verwendet wird. Dies wird Ihnen über eine Markierung in Form von Punkten in der Navigationsleiste angezeigt. Die Module, in welchen eine aktuell aufgerufene Person aktiv verwendet wird, markiert iMikel mit zwei Punkten (rot und schwarz). Die Module, in welchen eine Person in der Vergangenheit verknüpft war, aktuell aber nicht mehr verwendet wird, werden mit nur einem schwarzen Punkt markiert.

iMikel_Navigationsleiste_Unterschied_Punkte.png

Diese Punkte sind der Hinweis dafür, dass das angezeigte Modul mit einem Bezug geöffnet werden kann. Beispielsweise haben Sie eine Person in der Adressverwaltung aufgerufen. Sie sehen die zwei Punkte in der Navigationsleiste hinter der Modulbezeichnung Unterricht. Wenn Sie auf das Modul Unterricht klicken, wird dieses mit einem Bezug geöffnet und zeigt Ihnen den Unterricht an, der zu der zuvor aufgerufenen Person aus der Adressverwaltung gehört.

Das Öffnen eines Moduls mit einem Bezug funktioniert auch mit mehreren aufgerufenen Datensätzen. Wenn Sie beispielsweise mehrere Personen in der Adressverwaltung aufgerufen haben und mit gedrückter ALT-Taste in die Unterrichtsverwaltung wechseln, wird Ihnen der Unterricht zu allen zuvor in der Adressverwaltung aufgerufenen Personen angezeigt.

In der Unterrichtsverwaltung ist dies ebenso über den Wechsel der Reiter (Veranstaltungen, Belegungen, Abrechnung) möglich.

Verschiedene Reiter und Registerkarten

Die Navigation innerhalb eines Moduls erfolgt über verschiedene Reiter und Registerkarten. Über diese können Sie in verschiedene Bereiche des Moduls wechseln. Wenn die Bezeichnung der Registerkarte grau und kursiv ist, bedeutet dies, dass es in diesem Bereich keinen Inhalt gibt.

iMikel_Unterrichtsverwaltung_Veranstaltungen.png

Eingabe von Datumsfeldern

Datumsfelder haben in allen Eingabemasken ein Kalender-Symbol, über welches ein Kalender eingeblendet werden kann.

Alternativ zur Auswahl eines Datums über den Kalender kann das Datum auch manuell eingegeben werden. Dabei ist Ihnen iMikel behilflich und korrigiert automatisch ein falsch eingetragenes Datum und ändert es auf den nächstmöglichen korrekten Wert.

Wird z. B. der 31.06.2022 eingegeben, wird dieser automatisch auf den 30.06.2022 korrigiert. Wenn Sie z. B. bei der Abmeldung eines Schülers zum Februar 2022 nicht wissen, ob der Februar 29 oder 28 Tage hat, geben Sie einfach 30.02.2022 als Austritt ein und iMikel korrigiert die Eingabe automatisch auf den 28.02.2022.

Alternativ können Sie sogar die Punkte weglassen und einfach 300222 eingeben, was iMikel ebenfalls auf den 28.02.2022 korrigiert.

Die Bedienelemente

Tastaturbefehle

In iMikel gibt es verschiedene Bedienelemente, die Sie in allen Bereichen des Programms wiederfinden und welche elementar für die Benutzung von iMikel sind. Im Folgenden werden diese erläutert.

WindowsmacOSAktion
STRG + A⌘ + AAlle Datensätze aufrufen (bzw. alles auswählen, wenn der Cursor in einem Feld steht)
STRG + ⇧ + A⌘ + ⇧ + AAusgeschlossene anzeigen (alle anderen/nicht aufgerufenen Datensätze anzeigen)
STRG + ALT + A⌘ + ⌥ + AMarkiert einen bestimmten Bereich (von-bis)
STRG + C⌘ + CKopieren
STRG + E⌘ + EDatensatz löschen
STRG + F⌘ + FDatensätze suchen
STRG + ⇧ + F⌘ + ⇧ + FDatensätze suchen (bisherige Auswahl wird um das Suchergebnis erweitert)
STRG + ALT + F⌘ + ⌥ + FDatensätze suchen (bisherige Auswahl wird auf das Sucherkriterium eingegrenzt)
⇧ + ALT + F⇧ + ⌥ + FLetzte Suchabfrage bearbeiten
STRG + I⌘ + IAus Index einfügen
STRG + K⌘ + KKriterium ausschließen
STRG + N⌘ + NNeuer Datensatz (Neue / weitere Suchabfrage, wenn im Suchenmodus)
STRG + ⇧ + N⌘ + ⇧ + NNeues Fenster (Duplikat des bisherigen Fensters)
STRG + O⌘ + ODatei öffnen
STRG + ⇧ + O⌘ + ⇧ + ODatei vom Server öffnen
STRG + Q⌘ + QProgramm beenden
STRG + V⌘ + VEinsetzen
STRG + W⌘ + WDatei bzw. Fenster schließen
STRG + ⇧ + W⌘ + ⇧ + WAlle Dateien schließen
STRG + X⌘ + XAusschneiden
STRG + Z⌘ + ZRückgängig
STRG + -⌘ + -Diesen Datensatz ausschließen
STRG + ⇧ + -⌘ + ⇧ + -Mehrere Datensätze ausschließen
STRG + ALT + -⌘ + ⌥ + -Alle anderen Datensätze ausschließen
STRG + ↓⌘ + ↓Vorwärts Blättern
STRG + ↑⌘ + ↑Rückwärts Blättern
STRG + ←⌘ + ←Gehe zum ersten Datensatz
STRG + →⌘ + →Gehe zum letzten Datensatz

Tasten und Symbole

Viele Befehle und Aktionen werden in iMikel über Tasten vorgenommen. Diese sind verschiedene Symbole, die unterschiedliche Funktionen erfüllen. Folgend eine Erläuterung der Symbole:

Öffnet ein Menü zum Bearbeiten des Datensatzes oder für weitere Aktionen.

iMikel_Symbol_bearbeiten.png

Fügt einen Datensatz hinzu.

iMikel_Symbol_hinzufuegen.png

Löscht einen Datensatz.

iMikel_Symbol_Loeschen.png

Schließt einen Datensatz aus.

iMikel_Symbol_Ausschliessen.png

Springt zu einem Datensatz, um weitere Informationen zu diesem anzuzeigen.

iMikel_Symbo_Pfeil_orange.png

Öffnet ein Einstellungsmenü eines bestimmten Bereiches/Moduls.

iMikel_Symbol_Zahnrad.png

Öffnet das Protokoll, um einsehen zu können, welche Änderungen an einem Datensatz vorgenommen wurden.

iMikel_Symbol_Auge.png

Blendet überflüssige Angaben aus (z. B. stornierte Buchungen).

iMikel_Symbol_Besen.png

Öffnet ein Fenster zum Einsetzen/Auswechseln eines Datensatzes.

iMikel_Symbol_auswechseln.png

Öffnet ein Fenster zum Hinzufügen einer Notiz zum ausgewählten Datensatz.

iMikel_Symbol_Notiz.png

Kopiert den Feldinhalt in die Zwischenablage.

iMikel_Symbol_kopieren.png

Öffnet ein Fenster zur Auswahl einer Bilddatei, um diese einzufügen.

iMikel_Symbol_Bildatei.png

Dupliziert den aufgerufenen Datensatz.

iMikel_Symbol_duplizieren.png

Dokument als PDF-Datei speichern.

iMikel_Symbol_PDF.png

Öffnet eine Listenansicht.

iMikel_Symbol_Liste.png

Hinweis, dass die Berechnung von Gebühren oder Lehrerdeputaten noch nicht abgeschlossen ist.

iMikel_Symbol_Warndreieck.png

Einblendmenüs

Einblendmenüs sind bei Bedarf aufkommende Bedienflächen, die diverse Informationen und Aktionen enthalten.

Beispiel:

iMikel_Popover.png

In den meisten Fällen werden Sie ein Einblendmenü über das Stift-Symbol benutzen (wie im oberen Beispiel gezeigt). Dieses Symbol enthält die Aktionen und Funktionen, die am meisten gebraucht werden.

Seitensteuerelemente

Dieses Bedienelement erkennen Sie an kleinen nebeneinander liegenden grauen Punkten. Sie dienen dazu, zwischen verschiedenen Ansichten schnell hin und her zu wechseln. Der dunkle Punkt zeigt dabei die aktive Ansicht an.

iMikel_Seitensteuerelement.png

Die Kopfleiste

Die Kopfleiste befindet sich in jedem iMikel-Modul im oberen Teil des Fensters. Über die Kopfleiste können Sie beispielsweise durch Datensätze navigieren und Suchabfragen starten. Zudem wird in der Kopfleiste der Name des Moduls angezeigt, welches Sie zur Zeit geöffnet haben. Folgend eine Übersicht der Funktionen der Kopfleiste:

iMikel_Kopfleiste.png

Nachrichten aus iMikel an App versenden

In der Kopfleiste befindet sich auch das Symbol, über welches Sie Nachrichten aus iMikel an Ihre App-Nutzer versenden können, sofern Sie die App einsetzen.

#Erklärung
1Klicken Sie hier, um die Druckwahl zu öffnen oder die in der Übersicht angezeigten Daten direkt auszudrucken.
2Klicken Sie hier, um für die aktuell angezeigte Person oder Firma einen Brief zu erstellen und aus den zahlreichen frei definierbaren Textvorlagen eine Auswahl zu treffen.
3Klicken Sie hier, um für alle aktuell aufgerufenen Datensätze einen Serienbrief zu erstellen und auch hier aus den zahlreichen Textvorlagen eine Auswahl zu treffen.
4Klicken Sie hier, um für die aktuell angezeigte Person oder Firma eine SMS zu erstellen und zu verschicken (erfordert SMS-Kontingent). Mit gedrückter ALT-Taste werden hierbei alle aufgerufenen Datensätze einbezogen.
5Klicken Sie hier, um für die aktuell angezeigte Person oder Firma eine eMail zu erstellen und zu verschicken. Mit gedrückter ALT-Taste werden hierbei alle aufgerufenen Datensätze einbezogen.
6Klicken Sie hier, um für die aktuell angezeigte Person oder Firma eine Rechnung/Honorarabrechnung zu erstellen. Mit gedrückter ALT-Taste werden hierbei alle aufgerufenen Datensätze einbezogen (Nicht in allen Modulen verfügbar).
7Klicken Sie hier, um einen neuen Hauptdatensatz zu erstellen. Dieser bezieht sich auf den aktuell geöffneten Bereich. Beispiel: „Unterrichtsverwaltung“ > „Belegungen“ erstellt eine neue Belegung.
8Klicken Sie auf die Pfeiltasten, um zum nächsten oder vorherigen Datensatz zu blättern. Mit gedrückter ALT- Taste gelangen Sie zum ersten bzw. letzten Datensatz.
9Klicken Sie hier, um alle erfassten Datensätze aufzurufen (Über die Fußleiste lässt sich zusätzlich einstellen, ob hierbei alle Datensätze oder nur aktive Datensätze aufgerufen werden).
10Klicken Sie hier, um nach einem oder mehreren bestimmten Datensätzen zu suchen.
11Klicken Sie hier, um einen Suchbereich für das Schnellsuchfeld zu definieren.
12Schnellsuchfeld - Hier können Sie eine Suchabfrage in dem über Punkt 11 definierten Suchbereich durchführen.
13Dies ist die Anzahl der Datensätze auf Basis Ihrer zuletzt durchgeführten Suchabfrage. Im gezeigten Beispiel befinden wir uns auf dem ersten von 28263 Datensätzen. Wenn Sie mit den Pfeiltasten durch die aufgerufene Anzahl von Datensätzen navigieren, wird Ihnen hier angezeigt, bei welchem Datensatz Sie sich gerade befinden.
14Über diese Funktion können Sie die aktuell aufgerufenen Datensätze nach bestimmten Kriterien sortieren.

Die Fußleiste

Die Fußleiste befindet sich in jedem iMikel-Modul im unteren Teil des Fensters. Über diese ist es möglich, verschiedene Optionen einzustellen. Folgend eine Übersicht der Funktionen der Fußleiste:

iMikel_Fussleiste.png

#Erklärung
1Klicken Sie auf „ID“, um ein Einblendmenü mit weiteren Informationen zu diesem Datensatz zu erhalten.
2Zeigt die Datensatz-ID des aktuell aufgerufenen Datensatzes an. Ein Klick auf diese ID schließt alle anderen Datensätze aus der aktuellen Auswahl aus.
3Klicken Sie auf das Häkchen, um die Zeitraum-Funktion zu deaktivieren. Setzen Sie das Häkchen, um diese wieder zu aktivieren.
4An dieser Stelle können Sie ein Beginn- und Enddatum definieren, um in iMikel den Zeitraum einzuschränken. Es werden Ihnen dann nur Bezugsdatensätze angezeigt, die in dem eingestellten Zeitraum gültig sind. Wenn Sie zum Beispiel in der Unterrichtsverwaltung nur die Rabatte einer Person sehen möchten, die in einem bestimmten Schuljahr aktuell sind, können Sie den Zeitraum auf dieses gewünschte Schuljahr eingrenzen. Zudem können Sie hierüber auch gelöschte Datensätze sichtbar machen, indem Sie das Von-Datum auf „01.01.1900“ stellen.
5Klicken Sie auf die Zahnräder, um vordefinierte Zeiträume (z.B. aktuelles Jahr) auszuwählen. Über die Plus-Taste können Sie sich zudem eigene Zeiträume für das Schuljahr, Semester etc. erstellen*.
6Klicken Sie auf das Häkchen, um die Funktion „nur aktive anzeigen“ zu deaktivieren. Klicken Sie erneut, um diese wieder zu aktivieren. Ist diese Funktion aktiviert, werden bei Suchvorgängen über die Lupe und beim Aufrufen alle Datensätze über das Kreiselsymbol nur die zum eingestellten Datum aktiven Datensätze berücksichtigt.
7Klicken Sie auf das Häkchen, um die Funktion „aktiv ab“ zu deaktivieren. Klicken Sie erneut, um diese wieder zu aktivieren. Ist die Funktion“Aktiv ab“ aktiviert, so berücksichtigt iMikel beim Aufruf der aktiven Datensätze auch diejenigen, die erst später als das eingestellte Datum aktiv werden.
8Zeigt das aktuell eingestellte Datum an. Klicken Sie auf das Datum, um die Zeitreise-Funktion zu benutzen. Ist diese Funktion aktiviert, werden bei Suchvorgängen über die Lupe und beim Aufrufen aller Datensätze über das Kreiselsymbol nur die zum eingestellten Datum aktiven Datensätze berücksichtigt.

*zu 5: Ein Anwender mit dem Löschrecht iMikel - Einstellungen global kann jede eigene Zeitraumvorgabe löschen. Ein Anwender ohne dieses Löschrecht kann Zeitraumvorgaben nur löschen, wenn diese von ihm selbst angelegt wurden. Trifft eine der genannten Regelungen zu, wird neben der Zeitraumvorgabe die Löschtaste angezeigt.

Datensätze suchen, finden und verwenden

Das Suchen in iMikel ist eine elementare Funktion, die Sie täglich verwenden werden. Sie können in iMikel in jedem Modul und in jedem Feld suchen.

Starten einer Suche

Um in den Suchen-Modus zu gelangen, klicken Sie auf die Lupe, die sich in jedem Modul in der Kopfleiste befindet:

iMikel_Kopfleiste_Lupe.png

Sobald der Suchen-Modus gestartet wurde, werden alle überflüssigen Aktionssymbole ausgeblendet, sodass das gesamte Layout für die Suche übersichtlicher ist. Zudem werden Tasten für eine einfachere Handhabung in der Kopfleiste eingeblendet, über welche Sie die Suche abbrechen, die Suche starten oder eine weitere Suchabfrage hinzufügen können. Der Suchen-Modus sieht wie folgt aus:

iMikel_Suchenmodus.png

Sie können in jedes Feld hineinklicken, um einen Suchbegriff einzugeben. Beispielsweise können Sie in das Feld Lehrkraft einen bestimmten Namen eingeben, um alle Schüler einer Lehrkraft zu finden. Um die Suche zu starten, bestätigen Sie einfach mit der Enter-Taste oder klicken Sie auf Suche starten in der Kopfleiste. Anschließend wird Ihnen die Anzahl der gefunden Datensätze in der rechten oberen Ecke der Kopfleiste angezeigt, wie im folgenden Screenshot zu sehen:

iMikel_Kopfleiste_Suchergebnisse.png

Sie sehen, dass iMikel bei der Suche 183 Datensätze gefunden hat. Über die Pfeiltasten ist es möglich, durch diese hindurch zu blättern.

Gleichzeitige Suche in mehreren Feldern

Das Besondere am Suchmodus ist die Möglichkeit, in allen angezeigten Feldern gleichzeitig Suchkriterien eingeben zu können. Um beispielsweise alle Personen namens Meier aus Musterhausen zu suchen, gehen Sie wie folgt vor:

Klicken Sie auf die Lupe in der Kopfzeile. Der Suchmodus wird aktiviert.

Geben Sie im Feld Name das Wort Meier ein.

Geben Sie im Feld Adresse das Wort Musterhausen ein.

Um die Suchabfrage auszuführen, betätigen Sie die Enter-Taste Ihrer Tastatur. Es werden alle Personen mit dem Namen Meier aus Musterhausen aufgerufen.

Gleichzeitige Suche nach mehreren Bezeichnungen

Sie können in iMikel auch nach mehreren Personen gleichzeitig suchen. Wenn Sie zum Beispiel alle Personen mit den Namen Schulze und Meier suchen möchten, gehen Sie wie folgt vor:

Klicken Sie auf die Lupe in der Kopfzeile. Der Suchmodus wird aktiviert.

Geben Sie im Feld Name das Wort Meier ein.

Bestätigen Sie die Suche noch nicht, sondern klicken Sie auf weitere Abfrage in der Kopfzeile.

Geben Sie abermals in das Feld Name das Wort Schulze ein.

Um die doppelte Suchabfrage auszuführen, bestätigen Sie jetzt die Suche mit Enter (oder klicken auf Suche starten). Es werden alle Personen namens Meier und Schulze aufgerufen.

Sie können über weitere Abfrage beliebig viele Suchabfragen gleichzeitig starten. Die Anzahl der Suchabfragen wird in der Kopfleiste angezeigt. Über die Pfeiltasten können Sie durch Ihre Suchabfragen blättern.

Suchabfragen speichern

In vielen Modulen von iMikel steht eine Funktion zur Definition von gespeicherten Suchabfragen zur Verfügung. Über das Menü Filter > gespeicherte Suchabfragen können Sie aus der Unterrichts- und Personalverwaltung beliebige Abfragen definieren und benennen. Anschließend können Sie diese direkt aus dem Cockpit im Startfenster über das Lupen-Symbol aufrufen und die gespeicherte Suchabfrage starten.

Sie können in iMikel dann direkt nach dem Starten des Programmes aus dem Startfenster z. B. mit nur zwei Klicks alle Wartelisteneinträge für Klavier und Keyboard im Areal Nord aufrufen. Jeder Anwender kann für sich persönlich beliebig viele Anfragen definieren.

In jeder Abfrage können Sie unbegrenzt viele Suchkriterien kombinieren und Suchergebnisse erweitern, einschränken oder Kriterien ausschließen. Sie können hiermit z. B. sehr leicht die folgende Abfrage definieren:

Ergebnismenge suchen:

  • Fach ist Trompete
  • Areal ist Nord

Kriterium ausschließen:

  • Fach enthält Jeki

Diese Suche können Sie z. B. unter der Bezeichnung Trompetenunterricht in Nord (exkl. Jeki) speichern und jederzeit mit nur einem Klick erneut ausführen.

Jede Suchvorgabe kann bestimmten oder allen Benutzern zugänglich gemacht werden. Hierbei werden alle Zugriffsrechte berücksichtigt. Haben Sie z. B. eine Suchabfrage Honorarkräfte in Nord definiert, kann ein Anwender diese nur ausführen, wenn er die erforderlichen Zugriffsrechte (mindestens Lesen) für den Vertragsbereich in der Personalverwaltung hat.

Die gespeicherten Suchabfragen bieten viele Möglichkeiten, mit iMikel noch effizienter zu arbeiten. Diese Funktion wird über zukünftige Updates auch für weitere Module zur Verfügung stehen.

Operatoren und Funktionen in einer Suche

SymbolBeschreibungBeispiel
=Exakte Übereinstimmung mit den angegebenen ganzen Wörtern (nur ganzes Wort abgleichen)
nur = sucht nach leeren Feldern
=Markt findet Markt, Markt Dienstleistungen und Aktueller Markt - Analyse, aber nicht Marktanalyse oder Supermarkt. =Chris =Schmidt findet Chris Schmidt oder Schmidt Chris, aber nicht Chris oder Christoph Schmidtner.
==Exakte Übereinstimmung mit dem angegebenen Text (ganzes Feld abgleichen)==Johann findet Johann, aber nicht Johann Schmidt. ==Johann Schmidt findet Johann Schmidt, aber nicht Schmidt, Johann oder Johann Schmidtmer.
>Größer als der eingegebene Wert>95129
>9/7/2010
>M
>= oder ≥Größer oder gleich dem eingegebenen Wert>=100
>=9/7/2010
≥8:00
≥M
<Kleiner als der eingegebene Wert<40
<9/7/2010
<M
<= oder ≤Kleiner oder gleich dem eingegebenen Wert<=95129
≤05:00:00
<=M
..
oder … (zwei oder drei Punkte)
Innerhalb des angegebenen Bereichs12:30…17:30
1/1/2009..6/6/2010
A…M
Mo..Fr
*Steht für alle unbekannten Zeichen und sucht nach nicht leeren FeldernMeier findet Meisner und Meitinger.
J
r findet Jr. und Junior. phan findet Phan und Stephanie.
!Findet alle doppelten Werte! im Feld “Firma” findet alle Datensätze mit ABC GmbH und DEF AG, wenn doppelte Werte vorhanden sind
#Ein #-Zeichen für jede Ziffer# findet 3, aber nicht 30.
## findet 30, aber nicht 3 oder 300.
#3 findet 53 und 43, aber nicht 3.

Suchvorgänge unterscheiden keine Groß-/Kleinschreibung oder Breite. Beispiel: Eine Suche nach fred findet Fred ebenso wie die Suche nach FRED.

Wenn Sie nach einem Bereich von Informationen in Datums-, Zeit- und Zeitstempelfeldern suchen, brauchen Sie nicht alle Datums- oder Zeitkomponenten anzugeben. Beispielsweise können Sie 5.2022 anstelle von 01.05.2022…31.5.2022 eingeben, um alle Datumswerte im Mai 2022 zu finden.

Anzeigen der Suchergebnisse als Übersicht (Liste)

Nachdem Sie über den Suchmodus die gewünschten Datensätze aufgerufen haben, klicken Sie unterhalb der Kopfleiste auf den Reiter Übersicht.

iMikel_Uebersicht.png

Sie bekommen die aktuell aufgerufenen Datensätze in einer Listenform dargestellt.

In der Liste sehen Sie pro Datensatz modulbezogene Angaben. Beispielsweise werden bei einer Übersicht der Belegungen aus der Unterrichtsverwaltung Name, Geburtsdatum, Geschlecht, Fach, Lehrkraft etc. angezeigt.
Zudem kann die Liste nach Bedarf aufsteigend oder absteigend sortiert werden.

Wenn Sie die Liste z. B. alphabetisch nach dem Namen sortieren möchten, klicken Sie auf die Spaltenüberschrift Name. Die Daten werden anschließend alphabetisch sortiert. Wenn Sie erneut auf die Überschrift Name klicken, werden die Daten umgekehrt sortiert, d. h. die Sortierung der Daten erfolgt von Z bis A.

Dasselbe gilt für die entsprechenden weiteren Spalten, die in dieser Listendarstellung angezeigt werden.

Ausgewählte Datensätze in einer Übersicht markieren

Die Übersichten in iMikel bieten Ihnen viele Möglichkeiten, mit den gefundenen Datensätzen zu arbeiten. Sie können beispielsweise einen bestimmten Bereich von Datensätzen markieren, um nur für diese Datensätze weitere Aktionen durchzuführen.

Einige Tasten auf Ihrer Tastatur erfüllen dafür eine bestimmte Aufgabe.

iMikel_Tabelle_Uebersicht.png

Die einzelnen Schritte der Markierungen lassen sich über folgendes Symbol rückgängig machen.

iMikel_Symbol_neuzuordnen.png

Über das Serienbrief-Symbol in der Kopfleiste können Sie eine modulspezifische Korrespondenz für alle markierten Datensätze erstellen. Wenn kein Datensatz markiert ist, wird für alle Datensätze in der Übersicht eine Korrespondenz erstellt. Des Weiteren können Sie über den orange hinterlegten Pfeil alle markierten Datensätze in der Blätteransicht aufrufen.

Modulspezifische Listen drucken

Die Druckwahl

iMikel bietet Ihnen über die Druckwahl diverse Möglichkeiten, Ihre Daten in Druckform auszugeben. Beachten Sie, dass sowohl die Anzahl der gedruckten Daten, als auch die Sortierung des Ausdrucks von Ihrer vorherigen Suchabfrage bzw. von den aktuell aufgerufenen Datensätzen abhängt.

Die Druckwahl finden Sie in jedem Modul im unteren Bereich der Navigationsleiste (in der Buchhaltung erreichen Sie die Druckwahl über das Druckersymbol in der Kopfleiste).

iMikel_Navigation_Druckwahl.png

Mit einem Klick auf die Druckwahl öffnet sich ein Fenster mit einer Auswahl von modulspezifischen Listen, Übersichten, Statistiken, Etiketten etc. Diese sind in verschiedene Kategorien unterteilt und befinden sich in entsprechenden Ordnern und ggf. Unterordnern.

Welche Arten von Listen sind in welchem Modul zu finden?

Viele Arten von Listen sind nur in bestimmten Modulen verfügbar. Entnehmen Sie bitte folgender Übersicht, in welchen Modulen bestimmte Listen vorhanden sind.

ModuleListen
KontenverwaltungAdress-Etiketten
Adress- und Telefonlisten
Abrechnungslisten
BuchhaltungBuchungslisten
Statistiken
UnterrichtsverwaltungAnwesenheitslisten / Stundenpläne
Teilnehmerlisten
Beratungsgesprächslisten
Adress- und Telefonlisten
Raumbelegungen
Wartelistendaten
Übersichten
Vorspiellisten
Statistiken
FächerverwaltungÜbersicht
Statistiken
VeranstaltungsorteRaumbelegungspläne
Türschilder
ArealeStatistiken
AdressverwaltungAdress-Etiketten
Adress- und Telefonlisten
Sonstige (Geburtstagsliste, Konferenzliste)
LehrerverwaltungUnterrichtsdaten (z.B. Anwesenheitslisten, Stundenpläne, Ab- und Ummeldelisten etc
Adress-Etiketten
Adress- und Telefonlisten
Verzeichnisse (z.B. Mitarbeiterverzeichnis
Sonstige Listen (Personalliste, Konferenzliste etc.)
Statistiken
HonorarverwaltungHonorarabrechnungen
Finanzamt-Bescheinigung
InventarverwaltungInventar Stammblatt
Inventarlisten
Strichcode-Etiketten
BibliothekenverwaltungObjektlisten
Strichcode-Etiketten

Bei Anwesenheitslisten mit zusätzlichen Spalten ist der Text im Kopf- und Fußteil frei definierbar. Hierbei stehen folgende Platzhalter zur Verfügung.

«Datum»
«ZeitraumBeginn»
«ZeitraumEnde»
«Monat»
«Jahr»
«Name»
«Briefanrede»
«Adressetikett»
«Straße»
«Postleitzahl»
«Ort»
«UmsatzsteuerId»
«IBAN»
«BIC»

Alle in der Druckwahl mit einem Stern gekennzeichneten Listen übernehmen immer die Sortierfolge des aufrufenden Moduls, auch wenn die Datensätze statt über die Sortiertaste z. B. über die Spaltenüberschriften in einer Übersicht sortiert wurden.

Einstellungen der Druckwahl

In der Fußleiste der Druckwahl gibt es einige Einstellungsmöglichkeiten, die im Folgenden erläutert werden.

iMikel_Druckwahl_Fussleiste.png

Druckereinrichtung: (De-)aktiviert den Dialog für die Druckereinrichtung (Format, Ausrichtung etc.). Ist diese Option aktiv, werden Sie beim Drucken einer Liste zum Einrichten des Druckers aufgefordert.

Voransicht: (De-)aktiviert die Voransicht. Ist diese Option aktiviert, erhalten Sie beim Drucken einer Liste zunächst eine Voransicht.

Druckdialog: (De-)aktiviert den Druckdialog. Ist diese Option aktiviert, werden Sie beim Drucken einer Liste aufgefordert, einen Drucker auszuwählen.

Es gibt Listen, die zusätzlich eigene individuelle Einstellungsmöglichkeiten haben.

Am häufigsten benutzt

Da Sie in der Druckwahl eine Vielzahl an Druckmöglichkeiten haben, von denen Sie aber während Ihrer täglichen Arbeit mit iMikel oft nur bestimmte benötigen, werden diese im Kopf der Druckwahl im Bereich am häufigsten benutzt angezeigt.

Diese Funktion bedeutet am häufigsten benutzt und nicht zuletzt verwendet.

Erzeugen von PDF-Dateien

Die Druckwahl bietet Ihnen zusätzlich zu dem normalen Ausdruck eines Dokumentes auch die Möglichkeit, den Druck direkt in eine PDF-Datei umzuwandeln. Klicken Sie dazu z. B. neben dem Wort Adressliste auf das PDF-Symbol.

iMikel_Symbol_PDF_erzeugen.png

Es öffnet sich das Dialogfeld zur Eingabe einer Überschrift.

Nachdem Sie die Überschrift bestätigt haben, öffnet sich ein Dialogfeld zum Eingeben eines Namens für die gewünschte PDF-Datei.

Des Weiteren können Sie den gewünschten Speicherort festlegen.

In vielen Fällen hat eine zu druckende Liste, Auswertung etc. mehrere Seiten. Sobald Sie das gewünschte Dokument aus der Druckwahl ausgewählt haben, öffnet sich die Druck-Voransicht (falls aktiviert). In dieser befinden sich am Anfang der Kopfleiste zwei Pfeiltasten (vor und zurück).

iMikel_Kopfleiste_Druckvoransicht.png

Über diese Pfeiltasten ist es Ihnen möglich, durch die Seiten zu blättern, bevor Sie diese drucken.

Notizen und Wiedervorlagen

Eingabe von Notizen

Sie haben in iMikel in jedem Modul die Möglichkeit, beliebig viele Notizen zum aufgerufenen Datensatz zu hinterlegen.

Klicken Sie auf das Notiz-Symbol, um eine neue Notiz zu erstellen.

iMikel_Symbol_neue_Notiz.png

Es öffnet sich das Fenster zur Eingabe einer neuen Notiz.

Das Symbol wird anders dargestellt, sofern bereits mindestens eine Notiz vorhanden ist:

iMikel_Symbol_Notiz_vorhanden.png

Notizen verwalten

Im Folgenden wird das Fenster zum Verwalten der Notizen erläutert.

iMikel_Notizen_Funktionen.png

Auf der rechten Seite können Sie die Notiz als Wiedervorlage kennzeichnen oder als terminierte Aufgabe. Über Benutzer hinzufügen können Sie aus der Liste aller Benutzer diejenigen Kolleg:innen auswählen, für welche die Notiz, die Wiedervorlage oder die terminierte Aufgabe relevant ist.

Notizen als Wiedervorlage

In iMikel sind Notizen deshalb wichtig, weil sie Ihnen Wiedervorlagen und Aufgabenterminierungen ermöglichen.

Sie können einen Benutzer über das grüne Plus für eine Wiedervorlage hinzufügen. Über das rote X haben Sie die Möglichkeit, einen Benutzer zu entfernen (s. Screenshot oben).

Ist das für eine Wiedervorlage vorgegebene Datum erreicht, weist iMikel die zugewiesenen Benutzer im Startfenster über das Symbol einer Briefmarke darauf hin.

Einige Wiedervorlagen sind als eilig einzustufen, andere als Aufgaben mit mittlerer Bedeutung. Mit iMikel können Sie die einzelnen Wiedervorlagen benutzerspezifisch priorisieren. Klicken Sie dafür in das Feld Priorität und wählen in dem Einblendmenü das passende Prädikat aus.

Des Weiteren können Sie jede Wiedervorlage als terminierte Aufgabe definieren, indem Sie in dem Feld erledigen bis ein Datum eingeben. Diese Terminierungen können Sie wie oben beschrieben benutzerspezifisch definieren.

Daten exportieren

Wenn Sie Datensätze in einem anderen Programm verarbeiten möchten, können Sie die Daten exportieren.

Treffen Sie zunächst eine Auswahl der gewünschten Datensätze (alle oder nur eine bestimmte Auswahl), die Sie exportieren möchten.

Wählen Sie die Funktion Datensätze > Export > Daten -> Datei.

iMikel_Daten_exportieren.png

Es öffnet sich ein Eingabedialog, in welchem Sie den Namen, das Format und den Speicherort der Ausgabedatei bestimmen können.

Klicken Sie anschließend auf den Button Speichern und die Exportdatei wird erstellt. Sie finden die Datei in dem von Ihnen angegebenen Speicherort auf der Festplatte Ihres Computers.

Diese Funktion steht nur in ausgewählten Modulen zur Verfügung.

Kopf- und Fußleiste personalisieren

In der linken oberen Ecke wird in allen Modulen die Bezeichnung des Moduls (z. B. Unterrichtsverwaltung) angezeigt. Mit einem Klick auf diese Modulbezeichnung öffnet sich ein Auswahlmenü, über welches die Hintergrundfarbe der Kopf- und Fußleiste ausgewählt werden kann.

iMikel_Farbauswahl.png

Halten Sie beim Klicken auf die Modulbezeichnung die Shift-Taste gedrückt und wählen Sie anschließend eine Farbe aus, so ändert sich nur die Farbe der Kopfleiste. Die Farbauswahl bezieht sich immer auf das Modul, in welchem Sie sich befinden, sodass Sie für jedes Modul eine eigene Farbe auswählen kann.

Die iMikel-Zeitreise

Mit der Zeitreise können Sie sich die Zustände der Vergangenheit (z. B. von vor zehn Tagen) und bereits hinterlegter Zukunft anschauen, bevor Sie letzte Änderungen durchgeführt haben. Somit können Sie z. B. Namensänderungen von Personen zurückverfolgen oder die Unterrichtstermine bestimmter Lehrkräfte in verschiedenen Jahren einsehen.

Das bei der Zeitreise eingestellte Datum gilt für alle Module in iMikel. Auf diese Weise werden Ihnen neben der Tages-, Wochen-, Monats- und Jahresübersicht auch die Terminliste und die Verwaltung unerledigter Arbeiten präsentiert.

Die Zeitreise ermöglicht somit die Konstruierung zukünftiger bzw. Rekonstruierung vergangener Verwaltungszustände an der Schule zu einem bestimmten Stichtag. Sie unterscheidet sich somit von der Betrachtung bestimmter Zeiträume (zum Beispiel: 01.08.2022 - 31.07.2022), die bei Bedarf ebenfalls Verwaltungszustände in der Zukunft und/oder in der Vergangenheit umfassen. Zeiträume ermöglichen die Betrachtung bestimmter Abrechnungsperioden.

Wie starte ich die Zeitreise?

In allen Modulen sehen Sie in der rechten Ecke der Fußleiste das aktuelle Datum. Wenn Sie auf dieses Datum klicken, öffnet sich ein Kalender. Das aktuelle Datum wird in diesem Kalender rot dargestellt:

iMikel_Zeitreise_Kalender.png

Wenn Sie in dem Kalender auf ein Datum klicken, wird dieses Datum übernommen und der Kalender automatisch wieder geschlossen. Anschließend wird das gewählte Datum in Ihrer Fußleiste zusammen mit einem roten Ausrufezeichen angezeigt.

Dieses Ausrufezeichen weist Sie darauf hin, dass Sie gerade NICHT in der Gegenwart sind, sondern dass Ihnen die Daten der Zukunft oder der Vergangenheit angezeigt werden.

Moduleinstellungen

Moduleinstellung öffnen

Jedes Modul in iMikel hat eigene individuelle Einstellungen. Diese lassen sich über das Zahnradsymbol in dem jeweiligen Modul öffnen. Dieses Symbol befindet sich in jedem Modul an der gleichen Stelle.

Startfenster_Einstellungen.png

Wertelisten in den Einstellungen

Viele Einstellungen in iMikel enthalten Wertelisten, mit denen verschiedene Vorgaben definiert werden können. Da diese Wertelisten wichtige Datensätze enthalten, die mit anderen Bereichen verknüpft sind, lassen sich diese Datensätze nur löschen, sofern diese in keinem Bereich in iMikel verwendet werden.

Ist das Löschen deshalb nicht möglich, wird das rote X zum Löschen ausgeblendet. Folgend ein Beispiel aus der Personalverwaltung.

iMikel_Wertelisten_Symbol_loeschen.png

Bestimmte Einstellungen schnell finden

Für einen noch schnelleren Zugriff auf bestimmte Einstellungen kann direkt aus dem Startfenster eine Übersicht mit allen Moduleinstellungen aufgerufen werden. Dafür reicht ein einfacher Klick auf das Zahnradsymbol im Cockpit.

iMikel_Startfenster_Symbol_Einstellungen.png

Dadurch haben es Administratoren wesentlich leichter, Einstellungen zu finden, da zudem über ein Suchfeld die Einstellungen nach Stichwörtern durchsucht werden können. Möchten Sie z. B. die Zahlweise anpassen, genügt es, diesen Begriff in das Suchfeld einzutragen. iMikel findet sofort die dazugehörige Einstellung.

iMikel_Startfenster_Einstellungen_suchen.png

CronJobs

Was sind CronJobs?

CronJobs sind Aufgaben, die automatisiert und im Hintergrund durch Ihren Server vorgenommen werden. Durch neue Server-Technologien können direkt am Server mehrere parallele Aktionen, Skripte, Zeitpläne und Arbeitsprozesse (abhängig von Prozessorleistung und Arbeitsspeicher am Server) durchgeführt werden. Diese Schritte brauchen somit nicht mehr am einzelnen Arbeitsplatz gestartet werden, was eine enorme Zeitersparnis bedeutet. Dazu zählen:

  • Automatische Aktualisierung von Gebühren im Hintergrund durch den Server

  • Automatische Aktualisierung von Lehrerdeputaten im Hintergrund durch den Server

  • Automatische Aktualisierung von Statistiken im Hintergrund durch den Server

  • Automatische Aktualisierung von Unterrichtsterminen im Hintergrund durch den Server

  • Automatische Datenpflege und Datenaufbereitung

Beispiel: Sie geben den Unterricht für eine neue Person in iMikel ein. Alle darauffolgenden Aufgaben werden vom Programm automatisch erkannt. Dies bedeutet, dass automatisch die Termine für diesen Unterricht erzeugt sowie die Gebühren berechnet werden und das Deputat aktualisiert wird.
Der einzige Arbeitsschritt, der dann noch von Ihnen zu übernehmen ist, ist das Erstellen der Rechnung. Alle anderen Arbeitsschritte wurden bereits vom Server übernommen.

Aktivität der CronJobs kontrollieren und verwalten

Aktivieren Sie vorab die Option Benutzer darf CronJobs verwalten bei den Eigenschaften der Benutzer in der Benutzerverwaltung, die das Recht haben sollen, die CronJobs verwalten zu dürfen.

iMikel_Benutzerverwaltung_Eigenschaften_BenutzerDarfCronJobsVerwalten.png

Eine Übersicht der momentan aktiven CronJobs lässt sich aus dem Cockpit des Startfensters öffnen. Klicken Sie dazu auf das Listen-Symbol.

iMikel_Startfenster_Symbol_CronJobs_verwalten.png

Die Übersicht zeigt eine ausführliche Auflistung aller aktiven CronJobs.

iMikel_CronJobs_Kopfleiste.png

Status der CronJobs

Ein CronJob kann einen von drei verschiedenen Status haben.

iMikel_CronJobs_Farben.png

Mit einem Klick auf einen Status wird dieser auf den Status 0 zurückgesetzt und somit neugestartet.

CronJobs deaktivieren

Sie können die automatische Hintergrundaktualisierung wie folgt deaktivieren:

Klicken Sie im Startfenster auf das Listen-Symbol, um die Übersicht der CronJobs zu öffnen.

iMikel_Startfenster_Symbol_CronJobs_verwalten.png

Auf der rechten Seite ist eine grüne Schaltfläche zu sehen, auf welcher CronJobs aktiv steht. Klicken Sie auf diese Schaltfläche.

Es öffnet sich anschließend ein Fenster, in welchem Sie definieren können, bis zu welchem Zeitpunkt die CronJobs pausieren sollen.

iMikel_CronJobs_pausieren.png

Eigene Felder

Im Bereich Eigene Felder ist die Eingabe weiterer Informationen möglich, nach denen Sie später suchen können. Auf diese Weise können Sie selbständig neue Felder generieren, die Ihnen in den anderen Datensätzen ebenfalls zur Verfügung stehen.

Eigene Felder stehen Ihnen in vielen verschiedenen Modulen zur Verfügung.

Die Erstellung von eigenen Feldern funktioniert ganz leicht mit Hilfe eines Eingabeassistenten, welcher im Folgenden erklärt wird.

Klicken Sie im Bereich Eigene Felder auf das grüne Plus.

iMikel_Symbol_neue_eigene_Felder.png

Daraufhin öffnet sich der Assistent.

iMikel_Eigene_Felder_Assistent.png

Schritt 1: Im ersten Schritt können Sie auswählen, ob Sie ein schon vorhandenes Feld nehmen oder ein neues Feld erstellen.

Beispiel: allergisch gegen

Schritt 2: Im zweiten Schritt definieren Sie den Wert für das zuvor ausgewählte Feld.

Beispiel: Nüsse

Schritt 3: Im dritten Schritt können Sie optional einstellen, ob das zuvor definierte Feld bei allen aufgerufenen Datensätzen eingefügt wird.
Des Weiteren können Sie einstellen, ob bereits vorhandene Feldwerte mit den aktuell ausgewählten Feldwerten zu überschreiben sind.

Klicken Sie auf OK, um die Erstellung der eigenen Felder zu starten.

Über das rote X lässt sich ein eingegebenes Feld wieder entfernen. Wenn Sie dabei die Shift-Taste gedrückt halten, werden alle eigenen Felder mit dem gleichen Inhalt bei allen aufgerufenen Datensätzen entfernt.

Rettungsringe

Rettungsringe sind in iMikel der Hinweis darauf, dass ein Fehler vorliegt. In den meisten Fällen ist die Ursache des Rettungsringes zu beheben, damit das Programm weiterarbeiten kann.

Ein Rettungsring wird über folgendes Icon symbolisiert.

iMikel_Symbol_Rettungsring.png

Halten Sie die Maus ein paar Sekunden über den Rettungsring, um einen Tooltip einzublenden. Der Tooltip zeigt eine Beschreibung des Fehlers und eine Info, wie Sie diesen Fehler beheben können.

iMikel_Unterrichtsverwaltung_Rettungsring_Tooltip.png

Über das Startfenster haben Sie zudem die Möglichkeit, über die Funktion Ergebnisprüfung/Rettungsringe suchen alle Rettungsringe anzuzeigen, die im Programm vorhanden sind. Die Rettungsringe werden gruppiert pro Modul dargestellt. Über die orangefarbenen Pfeile können Sie die entsprechenden Datensätze aufrufen und diese bearbeiten.

Ist die Funktion Ergebnisprüfung/Rettungsringe suchen bei Ihnen nicht im Startfenster verfügbar, kann diese ganz einfach hinzugefügt werden, indem Sie im Startfenster bei Meine Funktionen auf das Zahnradsymbol klicken.

Eigene Formeln und Texte für Schnellbefehle hinzufügen

In vielen Modulen lassen sich über den Menüpunkt Bearbeiten> Einfügen > Formeln konfigurieren` eigene Texte und Formeln definieren.

Hierbei stehen Ihnen zehn verschiedene Schnellbefehle zur Verfügung.

Die Schnellbefehle lassen sich über die Tasten STRG + die Ziffern 1-0 ausführen (Unter macOS mit der Taste CMD).

Standardmäßig sind die Befehle 1-4 mit Formeln hinterlegt, welche für die alltägliche Arbeit mit iMikel nützlich sein können. Über die Taste Standard können Sie bei Bedarf diesen Standard wiederherstellen.

Sie können jederzeit auch eigene Formeln oder Texte definieren, die dann beim Ausführen des Schnellbefehls eingefügt werden.

Diese Funktion steht in folgenden Modulen zur Verfügung:

-	Adressverwaltung  
-	Kontenverwaltung  
-	Inventarverwaltung  
-	Honorarverwaltung  
-	Fächerverwaltung  
-	Veranstaltungsorte  
-	Projektverwaltung

Hierbei können für jedes Modul individuell eigene Befehle konfiguriert werden.

Um einen Befehl zu konfigurieren, klicken Sie einfach auf die Ziffer, welche Sie als Schnellbefehl belegen möchten.

Tragen Sie in das Feld Menüeintrag eine Bezeichnung ein. Diese Bezeichnung wird auch unter dem Menüpunkt Bearbeiten > Einfügen erscheinen.

Geben Sie in das Feld Formel/Text Ihren gewünschten Inhalt ein.